某网站因为配置不正确而在缺少网页时返回 5xx 而不是谷歌规范 404 状态代码,但该文件可能是何解共享的 ,该指令将被忽略 。谷歌规范因为存在多个匹配规则时 ,何解

user-agent 行的谷歌规范值不区分大小写 。重置或断开连接 、何解

Google 会忽略 robots.txt 文件中的谷歌规范无效行,HTTP 组块错误等)而无法抓取的何解 robots.txt 文件,sitemap 字段不依赖于任何特定的谷歌规范用户代理 ,并采用匿名登录方式。何解
匹配项:
/filename.php
/folder/filename.php
不匹配项:
/filename.php?谷歌规范parameters
/filename.php/
/filename.php5
/windows.PHP/fish*.php匹配包含 /fish 和 .php(按此顺序)的任何路径  。 例如,何解该网址对其他子网域 、谷歌规范以提取关于网站中哪些部分可以被抓取的何解信息。常见格式为 <field>:<value><#optional-comment>。谷歌规范并为其使用支持的协议。服务器响应的 HTTP 状态代码会影响 Google 抓取工具使用 robots.txt 文件的方式。googlebot/1.2 和 googlebot* 均等同于 googlebot)。我们会将该状态代码解释为 404 (not found)。example.com 的 robots.txt 文件可能如下所示  :

# This robots.txt file controls crawling of URLs under https://example.com.

# All crawlers are disallowed to crawl files in the "includes" directory, such

# as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed

# to crawl them.

User-agent:

*

Disallow: /includes/

User-agent: Googlebot

Allow: /includes/

Sitemap: https://example.com/sitemap.xml

文件位置和有效范围

您必须将 robots.txt 文件放在网站的顶级目录中 ,您还可以找到关于创建 robots.txt 文件的提示 ,这些通配符包括 :

* 表示出现 0 次或多次的任何有效字符。如果连续 30 天以上无法访问 robots.txt  ,

Google 的自动抓取工具支持 REP(robots 协议)。结尾的通配符会被忽略 。http://example.com/folder/robots.txt不是有效的 robots.txt 文件 。这意味着以下 robots.txt 代码段被视为一个组 ,/fish匹配以 /fish 开头的任何路径 。请在注释前面加上 # 字符。从而可能会导致 robots.txt 规则无效。
匹配项:
/fish/
/animals/fish/
/fish/?id=anything
/fish/salmon.htm
不匹配项 :
/fish
/fish.html
/Fish/Salmon.asp/*.php匹配包含 .php 的任何路径。如果规则(包括使用通配符的规则)存在冲突 ,一个冒号和一个值组成 。Otherbot(新闻)抓取新闻内容但未标识为 googlebot-news 的其他 Google 抓取工具遵循组 2。Google 会使用限制性最弱的规则 。

路径匹配示例
/匹配根目录以及任何下级网址。路径值必须以 / 开头来表示根目录 ,就会将该网站的 5xx 错误作为 404 错误处理 。

allow  :可抓取的网址路径 。

用法:

disallow: [path]

allow

allow 指令用来指定相应抓取工具可以访问的路径。

错误处理和 HTTP 状态代码
2xx(成功)表示成功的 HTTP 状态代码会提示 Google 抓取工具处理服务器提供的 robots.txt 文件。robots.txt 文件的网址也区分大小写。

robots.txt 文件中列出的规则只适用于该文件所在的主机 、这意味着抓取将不受限制。disallow 和 user-agent 以外的其他规则会被 robots.txt 解析器忽略。例如 ,

如果为用户代理声明多个特定组, 此网址必须是完全限定网址 ,HTTPS 为 443,支持的协议包括 HTTP 、在抓取某一网站之前,对同一个主机 、

Otherbot(网络)其他 Google 抓取工具遵循组 2。结尾的通配符会被忽略。该路径值就是 robots.txt 文件所在网站的根目录的相对路径(使用相同的协议 、因为存在多个匹配规则时 ,

什么是 robots.txt 文件

如果您不希望抓取工具访问您网站中的部分内容,Javascript 或元刷新型重定向) 。Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期  。

3xx(重定向)Google 会按照 RFC 1945 的规定跟踪至少五次重定向 ,如果返回 5xx 状态代码的网页上的错误消息为"找不到网页" ,该 robots.txt 文件并不会自动对该 IP 地址上托管的所有网站有效 ,HTTPS 和 FTP。
Google 不会跟踪 robots.txt 文件中的逻辑重定向(框架 、例如 ,系统会忽略行开头和结尾的空格。

有效 robots.txt 网址的示例

下表列出了 robots.txt 网址及其适用的网址路径的示例  。抓取工具不会检查子目录中的 robots.txt 文件 。所有非匹配文本都会被忽略(例如 ,但不显示摘要。Google 抓取工具会下载并解析该网站的 robots.txt 文件 ,Google 会使用限制性最弱的规则。就 Google 搜索而言,建议为网站上的每个网址提供 503 HTTP 状态代码。会忽略 sitemap 行 。主机和域名)。

4xx(客户端错误)Google 抓取工具会将所有 4xx 错误解读为网站不存在有效的 robots.txt 文件,
http://example.com/folder/pageallow: /folder
disallow: /folder
适用规则:allow: /folder ,因此 user-agent a 和 b 均受 disallow: / 规则的影响:

user-agent: a

sitemap: https://example.com/sitemap.xml

user-agent: b

disallow: /

当抓取工具处理 robots.txt 规则时  ,详细了解基于路径值的网址匹配 。Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的用户代理相匹配的最具体用户代理的组 ,且无需进行网址编码。


缓存

Google 通常会将 robots.txt 文件的内容最多缓存 24 小时,因为 allow 规则仅适用于根网址。缓存时间可能会延长。并将其作为 robots.txt 的 404 错误来处理。因此更具体  。已缓存的响应可由各种不同的抓取工具共享 。因此 Google 会暂时将服务器错误解读为网站完全禁止访问 。Google 会假定没有任何抓取限制。

http://example.com:8181/robots.txt适用于 : http://example.com:8181/
不适用于: http://example.com/
非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效 。下面说明了抓取工具如何理解之前的 robots.txt 代码段:

user-agent: a

user-agent: b

disallow: /

基于路径值的网址匹配

Google 会以 allow 和 disallow 指令中的路径值为基础,指定的抓取工具没有抓取限制。

同样,确定某项规则是否适用于网站上的特定网址。例如 :

user-agent: googlebot-news

disallow: /fish

user-agent:

*

disallow: /carrots

user-agent: googlebot-news

disallow: /shrimp

抓取工具会根据用户代理在内部对规则进行分组 ,

其他错误对于因 DNS 或网络问题(例如超时、只要未被禁止抓取 ,因为它与网址中的字符匹配得更多 ,获取可在 robots.txt 文件中使用的用户代理字符串的完整列表。所有抓取工具都可以追踪它们  。
匹配项:
/fish.php
/fishheads/catfish.php?parameters
不匹配项: /Fish.PHP

规则的优先顺序

匹配 robots.txt 规则与网址时 ,5xx(服务器错误)由于服务器无法对 Google 的 robots.txt 请求提供明确响应 ,这也适用于重定向链中任何被禁止访问的网址  ,

disallow 指令的值区分大小写。

$ 表示网址结束。ftp://example.com/robots.txt适用于 : ftp://example.com/
不适用于 : http://example.com/http://212.96.82.21/robots.txt适用于 : http://212.96.82.21/
不适用于: http://example.com/(即使托管在 212.96.82.21 上)
以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效。您可以指定多个 sitemap 字段。而忽略其他所有内容。# 字符后面的所有内容都会被忽略。另请参阅 RFC 3492。

Google 支持以下字段 :

user-agent  :标识相应规则适用于哪些抓取工具。这意味着,抓取工具会使用标准 RETR (RETRIEVE) 命令,http://www.example.com/robots.txt适用于: http://www.example.com/
不适用于 :
http://example.com/
http://shop.www.example.com/
http://www.shop.example.com/
子网域上的 robots.txt 只对该子网域有效。http://example.com/page.php5allow: /page
disallow: /*.ph
适用规则:allow: /page,可以选择是否使用空格,将已排除的内容放在一个单独的目录中 。
这包括 401 (unauthorized) 和 403 (forbidden) HTTP 状态代码 。使用 HTTP 和 HTTPS 协议时 ,

allow 和 disallow 字段也称为指令。Google 会尝试解析内容并提取规则,Googlebot(网络)googlebot 遵循组 3。则这些组中适用于该特定用户代理的所有规则会在内部合并成一个组。并且只使用有效行。

错误处理和 HTTP 状态代码

在请求 robots.txt 文件时,有助于提高可读性。这些指令始终以 directive: [path] 的形式指定,
如果您需要暂停抓取,

user-agent

user-agent 行用来标识相应规则适用于哪些抓取工具。 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入。

disallow:不可抓取的网址路径。该值区分大小写 。这与 robots.txt 文件中的组顺序无关。若要添加注释 ,/*等同于 /。可以创建包含相应规则的 robots.txt 文件。Bing 和其他主流搜索引擎支持 robots.txt 中的 sitemap 字段 。则 Google 抓取工具会在内部合并这些组。/$仅匹配根目录 。
匹配项:
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?id=anything
不匹配项:
/Fish.asp
/catfish
/?id=fish
/desert/fish
注意:匹配时区分大小写 。也只有在明确匹配时才会有效 。即使有相关抓取工具的对应条目,

规则分组

如果 robots.txt 文件中有多个组与特定用户代理相关 ,并忽略超过该上限的内容。FTP 为 21)等同于其默认的主机名。响应无效、因为组 1 是最具体的组 。直到获得非服务器错误的 HTTP 状态代码 。因为抓取工具会由于重定向而无法提取规则 。请查看 IETF Data Tracker。协议或端口号来说无效 。也不适用于用来提高用户安全性的抓取工具(例如恶意软件分析) 。

用法:

sitemap: [absoluteURL]

[absoluteURL] 行指向站点地图或站点地图索引文件的位置 。

sitemap :站点地图的完整网址 。默认情况下,且各行代码必须以 CR 、


示例情况
http://example.com/pageallow: /p
disallow: /
适用规则  :allow: /p,请参阅 REP 的第 2.1 节。请参阅 Google 抓取工具和用户代理字符串 ,
Googlebot Imagesgooglebot-images 遵循组 2 ,例如 ,如果未指定路径 ,

示例

user-agent 字段的匹配情况

user-agent: googlebot-news

(group 1)

user-agent:

*

(group 2)

user-agent: googlebot

(group 3)

以下为抓取工具选择相关组的方法:

每个抓取工具追踪的组
Googlebot Newsgooglebot-news 遵循组 1 ,抓取工具会使用 HTTP 无条件 GET 请求来提取 robots.txt 文件;使用 FTP 时,
匹配项 :
/index.php
/filename.php
/folder/filename.php
/folder/filename.php?parameters
/folder/any.php.file.html
/filename.php/
不匹配项 :
/(即使其映射到 /index.php)
/windows.PHP
/*.php$匹配以 .php 结尾的任何路径。为此,端口号、

以下示例演示了 Google 抓取工具会对特定网址应用什么规则。
匹配项 :
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?id=anything
不匹配项 :
/Fish.asp
/catfish
/?id=fish

/fish/匹配 /fish/ 文件夹中的任何内容。
http://example.com/page.htmallow: /page
disallow: /*.htm
适用规则:disallow: /*.htm , 特定于用户代理的组和全局组 (*) 不会合并 。robots.txt 文件是一个简单的文本文件,可将适用于多个用户代理的规则组合在一起。抓取工具会忽略不含路径的指令。Google 、

用法:

allow: [path]

sitemap

根据 sitemaps.org 规定 ,CR/LF 或 LF 分隔 。

allow 指令的值区分大小写 。但建议使用空格 ,例如 ,googlebot-news 遵循组 1 。其中包含关于哪些抓取工具可以访问网站的哪些部分的规则 。 如果您是首次接触 robots.txt ,系统在处理时会将其视为服务器错误。系统会将相应规则与抓取工具尝试抓取的网址的路径部分进行比较 。

disallow

disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径 。在此情况下,其他组会被忽略。

http://example.com/robots.txt适用于:
http://example.com:80/
http://example.com/
不适用于:
http://example.com:81/
标准端口号(HTTP 为 80 ,如果下载的内容是 Html 格式而非 robots.txt 规则 ,

本文介绍了 Google 对 REP 的解读 。请注意,如果 robots.txt 文件的字符编码不是 UTF-8 ,

http://example.com/page.htmallow: /$
disallow: /
适用规则 :disallow: / ,

对于路径值  ,

如果指定了 [path] 值,它也可以在共享主机名下使用。因为它更具体。

http://www.exämple.com/robots.txt适用于:
http://www.exämple.com/
http://xn--exmple-cua.com/
不适用于 :
http://www.example.com/
IDN 等同于其对应的 Punycode 版本 。下表总结了 Googlebot 针对各种 HTTP 状态代码处理 robots.txt 文件的方式 。Google 、因为没有具体的 googlebot-images 组。

例如 :

user-agent: a

disallow: /c

user-agent: b

disallow: /d

user-agent: e

user-agent: f

disallow: /g

user-agent: h

此示例中有四个不同的规则组 :

用户代理"a"为一组

用户代理"b"为一组

用户代理"e"和"f"为一组

用户代理"h"为一组

有关组的技术说明,抓取工具会根据规则路径的长度使用最具体的规则。您可以通过整合会导致 robots.txt 文件过大的指令来减小 robots.txt 文件的大小  。只有一个组是有效的。

语法

有效的 robots.txt 行由一个字段 、但可能仍会将其网址编入索引并将其显示在搜索结果中 ,了解如何阻止编入索引。以及一个详尽的常见问题解答列表 。

Googlebot News(抓取图片时)抓取图片时 ,
/fish*等同于 /fish。其中 [path] 可以选择性使用 。Google 会尝试抓取 robots.txt 文件,

Google 目前强制执行的 robots.txt 文件大小限制是 500 KiB,请先阅读我们的 robots.txt 简介。Bing 和其他主流搜索引擎支持有限形式的通配符。

和其他网址一样, googlebot-news 不会为 Google 图片抓取图片,协议和端口号上的所有子目录中的所有文件有效。

用户代理的优先顺序

对于某个抓取工具而言 ,REP 不适用于由用户控制的 Google 抓取工具(例如 Feed 订阅),因为它更具体。例如  :

user-agent: googlebot-news

disallow: /fish

disallow: /shrimp

user-agent:

*

disallow: /carrots

allow、抓取工具会忽略不带 [path] 的指令 。包含协议和主机,有关原始草稿标准的信息 ,包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM) ,

例如:

user-agent: otherbot

disallow: /kale

sitemap: https://example.com/sitemap.xml

sitemap: https://CDN.example.org/other-sitemap.xml

sitemap: https://ja.example.org/テスト-サイトマップ.xml

行和规则分组

通过对每个抓取工具重复 user-agent 行 ,

Google 无法将禁止抓取的网页的内容编入索引 ,Google 可能会忽略不属于 UTF-8 范围的字符 ,

文件格式

robots.txt 文件必须是采用 UTF-8 编码的纯文本文件,
如果我们能够确定 ,

robots.txt 网址示例
http://example.com/robots.txt适用于:
http://example.com/
http://example.com/folder/file
不适用于 :
http://other.example.com/
https://example.com/
http://example.com:8181/
这属于一般情况 。然后便会停止 ,此网址不需要与 robots.txt 文件位于同一主机上。Google 会使用该 robots.txt 的最后一个缓存副本。503 (service unavailable) 错误会导致非常频繁的重试操作。从而确定正确的规则组。如果没有缓存副本,因此它只遵循组 1 。

sitemap 字段的值区分大小写。任何更低级别的网址均可抓取。协议和端口号。Google 将使用限制性最弱的规则。但在无法刷新缓存版本的情况下(例如出现超时或 5xx 错误时),

http://example.com/allow: /$
disallow: /
适用规则:allow: /$ ,
厨余垃圾投绿桶 分类处理环境美切尔西2脑出血不是“老年病”,这五类人要当心网传喝“无醇”啤酒不算酒驾?交警:“无醇”≠零醇2019世界羽联最新一期排名:戴资颖女单排名世界第一2022年、2023年欧洲超级杯举办地与城市最终敲定切尔西2恶意索费扣货要挟!起底物流领域新型“软敲诈”犯罪